Get in touch
Back
Resolved

Major provider outage

Started 17 Aug at 07:23am CEST.

Backend
Created

Our provider experienced a major outage that took longer than expected. To mitigate this we've switched to a more reliable solution. No data was lost.

Posted 17 Aug at 07:23am CEST.